Welcome to devpaks repository

wxWidgets-2.5.3-gcc3.3.1

Packagerspecu
spec at webtech dot pl
Version1
Last modified2005-01-31 19:53:22
Linkhttp://www.wxwidgets.org/
DescriptionThis is wxWidgets 2.5.3 Patch 02 unstable. WxWidgets gives you a single, easy-to-use API for writing GUI applications on multiple platforms.

This is wxWidgets 2.5.3 static unstable. It was compiled from source against plain Dev-C++ 4.9.9.0, with "./configure --prefix=c:/Dev-Cpp --enable-monolithic --disable-shared --disable-mslu --with-opengl --with-odbc". Please note that unicode is disabled in this build.

The package is based on wxWidgets package from upcase.de, except it was compiled from source against Dev-C++'s mingw system. It also containes Examples and Templates copied from Upcase's devpak.
CategoryGUI
Depends onlibjpeg 6b-4 zlib 1.2.2 libpng 1.2.8 libtiff 3.6.1-2
Downloadhttp://sourceforge.net/ project/ showfiles.php? group_id=94270& package_id=132908& release_id=275894
If download doesn't work use right mouse button on the filename and select Save Link As...
Authors of devpaks are responsible for their content!

You can register yourself to be notified of the changes to this devpak if you log in.

Comments:

May there is a fix by guest 2005-09-06 07:26:47
The same happened to me.
I tried then to install gtk+ and being in the update section i've also updated libjpeg, libpng and the mingw runtime and also the g++ compiler.
Afterwards I gave it one more try and it worked.

Good luck
samples by specu (spec at webtech dot pl) 2004-10-30 20:45:41
I tried few samples are all of them compiled fine. I'm preparing a new version of this package, because this one doesn't display non characters in localized programs - vide sample\internat
re: compilre mismatch by specu (spec at webtech dot pl) 2004-10-30 20:40:36
the package what compiled with gcc and mingw that comes with dev-c++ 4.9.9.1 - gcc version 3.3.1. What gcc are you using?
I see. by guest 2004-10-29 14:40:35
So I need to update gcc, yes? Hmmm...OK, let's see how it goes...
Compiler mismatch by guest 2004-10-28 13:56:47
That's a compiler mismatch.
The devpak libs were compiled with a newer version of gcc, the error occours if you try to link new programs with an older gcc release.
Doesn't work with samples by guest 2004-10-27 15:00:19
I tried to use the official WxWidgets 2.5.3 samples with this...It compiles fine. But when you run the app you just compiled, you get a mis-match error.

Somthing like :

"Mismatch between the program and library build version detected."

It points out that C++ ABI :
one is 102, the other one is 1002.

So basically, this devpak isn't quite ready yet.
Add new comment


Newlines are transformed to line-breaks ('<br />').

Spam protection: Please type the number 2 into the textbox:

Warning: comment is NOT automatically send to the author of the devpak, so if you need to contact author directly (e.g. you've found a bug) send it to the author's email.

You are not logged. New user Login